ошибка кабинета 3 версии

Форум технической поддержки продуктов компании Сетевые Решения
kid
Сообщения: 13
Зарегистрирован: 30 июн 2011, 14:05

ошибка кабинета 3 версии

Сообщение kid » 20 ноя 2018, 11:44

Добрый день, возникла проблема с установкой кабинета 3 версии. все ставил по инструкции https://www.lanbilling.ru/documentation/debian9-setup
система debian 9
установлены модули php

Код: Выделить всё

libapache2-mod-php5
libapache2-mod-php5.6
libapache2-mod-php7.0
php-common
php-pear
php5
php5-cli
php5-common
php5-gd
php5-json
php5-mcrypt
php5-memcache
php5-mysql
php5-readline
php5-suhosin
php5.6
php5.6-bcmath
php5.6-cli
php5.6-common
php5.6-curl
php5.6-gd
php5.6-gmp
php5.6-json
php5.6-mbstring
php5.6-mcrypt
php5.6-mysql
php5.6-opcache
php5.6-readline
php5.6-soap
php5.6-xml
php7.0
php7.0-bcmath
php7.0-cli
php7.0-common
php7.0-curl
php7.0-gd
php7.0-gmp
php7.0-json
php7.0-mbstring
php7.0-mcrypt
php7.0-mysql
php7.0-opcache
php7.0-readline
php7.0-soap
php7.0-xml


lbweb-client 3.1.0-1
lbweb-common 2.19.0-1

в логах апача пишет

Код: Выделить всё

[Tue Nov 20 11:31:23.548833 2018] [:error] [pid 26441] soap Failed to download wsdl (CUrl extension is not installed)
[Tue Nov 20 11:31:23.548912 2018] [:error] [pid 26441]  exception.Exception exception 'Exception' with message 'Failed to download wsdl' in /usr/share/lanbilling/phpclient/client/extensions/soap/SOAP_RemoteWSDL.php:90Stack trace:#0 /usr/share/lanbilling/phpclient/client/extensions/LANBilling.php(172): SOAP_RemoteWSDL->__construct(Object(LB\\HTTP\\Client), Array, Object(SOAPLoggers))#1 /usr/share/lanbilling/phpclient/framework/YiiBase.php(224): LANBilling->__construct()#2 /usr/share/lanbilling/phpclient/framework/base/CModule.php(393): YiiBase::createComponent(Array)#3 /usr/share/lanbilling/phpclient/framework/base/CModule.php(530): CModule->getComponent('lanbilling')#4 /usr/share/lanbilling/phpclient/framework/base/CApplication.php(168): CModule->preloadComponents()#5 /usr/share/lanbilling/phpclient/components/Application.php(11): CApplication->__construct(Array)#6 /usr/share/lanbilling/phpclient/framework/YiiBase.php(132): Application->__construct(Array)#7 /usr/share/lanbilling/phpclient/components/LBStart.php(152): YiiBase::createApplication('Application', Array)#8 /usr/share/lanbilling/phpclient/client/public/api.php(30): LBStart->run(Array)#9 {main}REQUEST_URI=/lbweb-client/---
[Tue Nov 20 11:31:23.548924 2018] [:error] [pid 26441]  soap Failed to download wsdl (CUrl extension is not installed)

соответственно ничего не открывается, что я не так делаю?

Аватара пользователя
support
Сообщения: 206
Зарегистрирован: 03 фев 2016, 10:41

Re: ошибка кабинета 3 версии

Сообщение support » 20 ноя 2018, 12:58

1. веб сервер (apache) с поддержкой версии PHP:
> 5.6.x - поддерживается релизами LANBilling 2.0.23 от 22.12.2017 и новее.
> 7.x - версия не поддерживается.
С какой версией у Вас работает Apache?

2. Failed to download wsdl
Какая версия АСР?
Настроен ли конфиг на доступ к ядру?
Сделана ли сериализация, если правился конфиг-файл?

kid
Сообщения: 13
Зарегистрирован: 30 июн 2011, 14:05

Re: ошибка кабинета 3 версии

Сообщение kid » 20 ноя 2018, 13:53

спасибо, разобрался. по умолчанию 5 версия пхп подцепилась, подцепил 7.0 версию и все завелось. спасибо.

megahertz
Сообщения: 25
Зарегистрирован: 13 окт 2015, 14:36

Re: ошибка кабинета 3 версии

Сообщение megahertz » 01 янв 2019, 21:46

Доброго дня
Столкнулся с такой же проблемой

Код: Выделить всё

[Tue Jan 01 21:56:17 2019] [error] [client 178.75.27.44] PHP Fatal error:  SOAP-ERROR: Parsing WSDL: Couldn't find <definitions> in '/var/lib/lanbilling/phpclient/client/api3.wsdl' in /usr/share/lanbilling/phpclient/client/extensions/SOAP.php on line 116, referer: http://x.x.x.x/api.php?r=site/login
[Tue Jan 01 21:56:17 2019] [error] [client 178.75.27.44] [LBClientSide]: /usr/share/lanbilling/phpclient/client/extensions/SOAP.php: SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't find <definitions> in '/var/lib/lanbilling/phpclient/client/api3.wsdl' in /usr/share/lanbilling/phpclient/client/extensions/SOAP.php:116\nStack trace:\n#0 /usr/share/lanbilling/phpclient/client/extensions/SOAP.php(116): SoapClient->SoapClient('/var/lib/lanbil...', Array)\n#1 /usr/share/lanbilling/phpclient/client/extensions/LANBilling.php(165): SOAP->__construct()\n#2 /usr/share/lanbilling/phpclient/framework/YiiBase.php(224): LANBilling->__construct()\n#3 /usr/share/lanbilling/phpclient/framework/base/CModule.php(393): YiiBase::createComponent(Array)\n#4 /usr/share/lanbilling/phpclient/framework/base/CModule.php(530): CModule->getComponent('lanbilling')\n#5 /usr/share/lanbilling/phpclient/framework/base/CApplication.php(168): CModule->preloadComponents()\n#6 /usr/share/lanbilling/phpclient/components/Application.php(11): CApplication->__construct(Array)\n#7 /usr/share/lanbilling/phpclient/framework/YiiBase.php(132): Application->__construct(Array)\n#8 /usr/share/lanbilling/phpclient/components/LBStart.php(152): YiiBase::createApplication('Application', Array)\n#9 /usr/share/lanbilling/phpclient/client/public/api.php(36): LBStart->run(Array)\n#10 {main}; at line 123, referer: http://x.x.x.x/api.php?r=site/login


Подобный лог вылазит при попытке авторизоваться в личном кабинете. При входе в админ-панель проблема не воспроизводится
php версии
[root@billing conf]# php -v
PHP 5.6.38 (cli) (built: Sep 12 2018 09:02:11)

столкнулся с проблемой только сегодня, ранее подобной проблемы не вылазило. В конфигах никаких изменений не вносилось.

Подскажите, куда смотреть?

megahertz
Сообщения: 25
Зарегистрирован: 13 окт 2015, 14:36

Re: ошибка кабинета 3 версии

Сообщение megahertz » 02 янв 2019, 10:33

Заработало без моего участия...так и не понял что было причиной. Кто-то сталкивался?

megahertz
Сообщения: 25
Зарегистрирован: 13 окт 2015, 14:36

Re: ошибка кабинета 3 версии

Сообщение megahertz » 12 янв 2019, 17:55

проблема снова проявилась. Неужели никто не может подсказать? представители lanbilling бывают на форуме?

kid
Сообщения: 13
Зарегистрирован: 30 июн 2011, 14:05

Re: ошибка кабинета 3 версии

Сообщение kid » 28 янв 2020, 11:35

у вас пхп не той версии подключена к веб серверу, переподключите модуль на 7 пхп и все.


Вернуться в «LANBilling: форум поддержки продукта»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 12 гостей